Logo

Was mir in Sachen Linux einfällt

Getestet mit Opensuse 12.2 RC2


Update vom September 2013: jetzt mit Opensuse 12.3 und Bumblebee (siehe unten)

Schenker/mysn XMG A 702

   Link zur Produktseite

Der Laptop draußen

Ausstattung:

Anschlüsse: VGA, HDMI, USB 2.0 1x, USB 3.0 3x, eSata, SD-Karten-Leser, S/PDIF out, Kopfhörer, Mikro, GByte-Netzwerk

Tastatur: normal mit Ziffernblock, Zusatztasten für Nvidia-Grafik, Webcam, Funk und Ton jeweils Ein/Aus

Zusätzlich von mir eingebaut: 2. (normale) Festplatte mit 500GB für /home

Auf diesem Notebook habe ich die SSD für die diversen Betriebsysteme vorgesehen und entsprechend vorher mit Gparted-Live partitioniert: 3 x 18GB für je ein OS, 4GB für swap und der Rest für ein kleines /home zum ersten Testen und einrichten. Zuerst kam wie immer zur Vermeidung von Schwierigkeiten Windows dran, in diesem Fall in der Version 7 Pro in 64-Bit. Damit bekam ich schon mal einen ersten Eindruck, wie sich ein Betriebsystem auf einer SSD installieren lässt. Ergebnis: Noch nie hat die Installation eines Betriebssystems so viel Spaß gemacht, den alles ging ratz fatz.

Opensuse kam dann dran, zuerst mit der Version 12.1 64-Bit Netzwerk, diese Installation sollte zum Arbeiten da sein. Allerdings brachte der startende Kernel die Grafik zum Flackern und musste mit "nomodeset" überredet werden. Als drittes OS dann Opensuse 12.2 RC2, auch in 64-Bit, auch Netzwerk zum Testen, diese Version brauchte keine Überredungskunst. Beide Betriebsystem ließen sich schnell installieren, wenn auch nicht so schnell, wie Windows, was nicht nur dran lag, dass bei Linuxen immer die Anwendungen mit dabei sind. Bei der Netzwerkinstallation ist die DSL-Leitung der Flaschenhals und der liegt bei mir bei 33Mbit entspricht 4Mbyte/sek.

Die Version 12.2 mit KDE funktionierte auf Anhieb so gut, dass ich deren Verhalten hier festhalte. Ich beschränke mich auf das, was nicht auf Anhieb funktionierte.

Die Zusatztasten funktionieren, die Anzeigen dafür sind gewöhnungsbedürftig, denn grün heißt "Aus" bzw. "Energie sparen" und eben nicht "An". Die FN-Tasten gehen bis auf Heller/Dunkler, damit habe ich mich nicht aufgehalten und eine Tastenkombi Strg/Shift/Dunkler bzw. Heller eingerichtet.

Das Display ist gut, lässt sich in einem weiten Bereich regeln und kann gut draußen benutzt werden (dank der matten Oberfläche). Die Lautsprecher sind für einen Laptop dieser Größenklasse ein wenig quäkig. Der Lüfter ist sehr leise bis leise. Das liegt sicherlich daran, dass ich keinen Highend-Prozessor bestellt habe, für unsere Zwecke reicht er völlig. Die Webcam lässt sich mit Luvcview ansprechen, das Programm liefert aber kein Bild, Wxcam ist jetzt für sie zuständig. S/PDIF-out kann ich nicht testen, eSata klappt, USB 3.0 hat beim Kopieren von 1,5 Gbyte Fotos 400Mbit bzw. 50Mbyte/sek erreicht, allerdings darf dann kein USB 2.0-Gerät am gleichen Port hängen. VGA und HDMI machten keine Probleme. Hier muss die KDE-Gemeinde noch nachbessern, denn nach dem Abziehen des zweiten Monitors kamen die entsprechenden Meldungen grundsätzlich auf dem zweiten Gerät an, obwohl ich den Notebook-Bildschirm ausdrücklich als Hauptbildschirm deklariert hatte. Erst Monitor abmelden und dann abziehen behebt solange dieses kleine Problem. Audio: null Problem, WLAN: dito.

Ruhezustand: beide funktionieren perfekt, Deckelschalter funktioniert.

Laufzeit: knapp 3 Stunden mit Büroarbeit und Surfen, ich habe keinerlei Energiespartechnik eingesetzt.

Update

Inzwischen habe ich dem Rechner ein Update gegönnt und jetzt läuft Opensuse 12.3 darauf. Das war für mich gleichzeitig die Gelegenheit, mit Hilfe von Bumblebee die Optimus-Technologie auszureizen. Und das funktioniert.

Die Installation ist inzwischen einfach geworden, wenn man wie folgt vorgeht:

Füge folgende Repositories ein die Liste der Quellen ein:

Dann installierst Du vom ersten das Paket "x11-video-nvidia" mit allen Abhängigkeiten und vom zweiten das Paket "bumblebee" ebenfalls mit etwaigen Abhängigkeiten. Danach editierst Du die Datei

/etc/bumblebee/bumblebee.conf

und änderst die Zeile mit "driver" in

driver=nvidia"

und auch im selben ordner die Datei

/etc/bumblebee/xorg.conf.nvidia

und ersetzt die Zeile

Option "ConnectedMonitor" "DFP"

durch

Option "ConnectedMonitor" "CRT"

Als letztes müssen alle User, die das feature benutzen wollen, der Gruppe "bumblebee" hinzugefügt werden z.B. durch

usermod -G bumblebee -a $USER

im jeweiligen Benutzerkonto. Nach einem Neustart sollte die grafische Oberfläche ohne Probleme laufen. Fehlt noch der Bumblebee-Daemon, der gestartet werden muss:

rcbumblebee start

Ein Programm, das auf die Nvidia-grafik zugreifen soll, muss ab jetzt mit

optirun programmname

gestartet werden. Dazu zwei Tests als normaler User:

glxinfo | grep OpenGL

und

optirun glxinfo | grep OpenGL

Bei den Tests muss jeweils "Intel" bzw. Nvidia" rauskommen. Wenn ja, dann gut, wenn nicht: Fehlersuche ...

Ich habe mir entsprechende Menüeinträge erstellt. Hier z-B. für "foobillard", bei dem die Grafik jetzt richtig flüssig laufen sollte:

optirun foobillard

Viel Spaß beim Spielen ...

Feedback Mein Gästebuch nach oben